Sierra House Cafe Recipes

Dressings

Beef Main Course

Fish Main Course

Sandwiches

Press this button to open report viewer


Beef Main Courses

Prime Rib


Sandwiches

Chicken Sandwich

Hot Turkey Sandwich

Ham Burger


Dressings

Vinegrette


Fish Main Courses

Baked Ahi


Baked Ahi

Service ware: Large round plate

Ingredients( In Order) | Regular Quantity | Lite Quantity | Cooking Procedures
Sesame Oil Fresh Fish Portion White Sesame seeds | 1 oz 8 oz 1 oz | 1 oz 5oz 3/4 oz | 1. Brush top surface of fish portions with seeds coating fish. Press lightly to set seeds into the flesh of the fish 2. Carefully place fish portion,(sesame side up) into the sauté pan and cook over Med. high heat until 2/3 done
Parsley Lemon Wedge | 1 Each 1 Each | 1 Each 1 Each | 3. Garnish with lemon wedge and italian parsley sprig 4. Place under the heat lamp


Burger

Ham Burger

Service Ware: Medium Oval Platter Date: 05/13/95

Ingredients (In Order):

Quantity

Cooking Procedure

Regular

Lite

Hamburger Patty, 7 oz.

Kosher Salt

1 each

1/4 tsp.

N/A

  1. Mold hamburger
  2. Place patty on Grill

French Fries, wt.

Kosher Salt

10 oz.

1/4 tsp.

  • Drop the french fries into the deep fryer set at 350° F and cook until they have turned golden.

    • Bun

    1 Each

  • Flip burger over and cook to desired doneness.
  • Open sourdough loaf by cutting in half lengthwise.

    • Tomato Slice

    Cheddar Cheese, 2 oz. Slices

    2 each

    1 each

  • Top the hamburger patty with two slices of tomato (side-by-side, not over lapped) and top the tomatoes with the cheese approximately 1-1/2 minutes prior to the burger being cooked to the proper temperature
  • Mound french fries next to (right side) the burger.
  • Place under the heat lamp.

    • NOTE: OPTIONS: 1/4 each Avocado; 2 oz. Sautéed Mushrooms; 2 sliced Smoked Bacon

    Red = Rare; Yellow & Red = Medium Rare; Yellow = Medium; Yellow & Dark = Medium Well; Dark = Well

    Ham Burger

    • Ground beef fresh, portioned daily
    • Salt and pepper portioned correctly
    • Caramelized onions recipe correct
    • Tomato slices fresh


Chicken Sandwich

Service Ware: Medium Oval Platter

Ingredients (In Order):

Quantity

Cooking Procedure

Regular

Lite

Chicken Breast Halves, 3 oz.

Blackened Spice

2 each

2 tsps.

N/A

  1. Sprinkle blackened spice on both sides of chicken breasts (do not over spice).
  2. Place chicken breasts on grill

White Bread, sliced

Margarine, melted

2 each

1 oz.

  • Roll the bread slices on the margarine spreader and grill to a golden brown.

    • French Fries, wt.

    Salt

    8 oz.

    1/4 tsp.

  • Drop the french fries into the deep fryer set at 350° F and cook until they have turned golden.

    • Chicken Sandwich

    • Margarine spread over the bread to ensure even toasting

    Blackened Chicken Sandwich Sand 3

    • Bread wrapped tightly to avoid cross contamination
    • Broiler cleaned frequently to avoid cross contamination
    • Raw chicken always stored at or below 40° F
    • Raw chicken always stored below ready to eat products i.e. lettuces
    • All chicken products cooked to a minimum temperature of 165° F
    • Knife and cutting board sanitized before and after each use


Blacken Prime rib

Prime Rib

Serviceware: Large platter, Glass bullet

Ingredients( In Order)

Regular Quantity

Lite Quantity

Cooking Procedures

Roast Beef, (approx 12 oz)

Blackened Spice

1 Slice

1/8 cup

N/A

  1. Slice of the prime rib portion midway between the two bones
  2. Grill the prime rib for 2 minutes on each side for rare, 3 minutes for medium rare,etc. (turning at the halfway point to create "diamond marks".)

French fries

6 oz

  • While the prime rib is grilling,
  • Drop the french fries and cook until golden brown

  • Top with cajun butter
  • Place fries to the left above the bone and onion strings to the right


Recipe Name

Turkey Sandwich

Service Ware: Oval Platter, Glass Bullet

Ingredients (In Order):

Quantity

Cooking Procedure

Regular

Lite

Cooked Turkey, sliced 1/4" thick

.

6 oz.

N/A

  1. Place turkey slices into the broth and set the pan underneath the frier
  2. Warm the turkey until thoroughly heated (about 4 minutes).

White Bread, sliced

Mashed Potatoes

Turkey Gravy (Hot)

2 each

8oz.

4 oz.

  • While the turkey is warming, cut the slices of white bread in half diagonally. Place them on the left side of the platter. They should be shingled with the pointed crust ends pointing upward and the cut straight edges facing down.
  • When the turkey is hot, remove the slices from the pan and lay them across the bread, completely covering the bread. The turkey slices may be shingled slightly if necessary. Discard chicken broth after each use.

    • NOTE: Ensure that the turkey slices are completely submerged during the heating process to maintain moisture. Turn slices over if necessary to prevent turkey from drying out.

    Turkey Sandwich

    • Oven roasted turkey fresh, moist, sliced per shift
    • Mashed potatoes

    Traditional Hot Turkey Sandwich Sand 19A

    • Bread wrapped tightly to avoid cross contamination
    • Slicer, knife and cutting board sanitized before and after each use
    • Clean all vegetables thoroughly before use
    • Turkey roasted to a minimum internal temperature of 165° F
    • Turkey chilled quickly and stored at or below 40° F
    • Check all plateware to ensure that there are no chips


Balsamic Vinigrette

Vinegrette

Prep Dressing

Portion: | Product: |  | Yield: 5 Gal
1/2 Gal |  | Vinegar
2 Cups |  | White Wine
2 Cups |  | Mustard
5Cups |  | Garlic, Chopped
1 1/2Cups |  | Salt
2 Cups |  | Sugar
1 1/2 Cups |  | Ground Black Pepper
2 Gals |  | Olive Oil
2 Gals |  | Canola Oil
4 Cups |  | Honey

Procedure:

In a clean mixing bowl, combine all ingredents except oil.

Transfer to a clean container.

Cover, date and store.